Menu

Problème Installation paquet

- - Dernière réponse : mamiemando
Messages postés
28650
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
17 décembre 2018
- 8 déc. 2018 à 19:40
Bonsoir

Je débute sur débian
Quand je fais apt-get install , on me dit "impossible de résoudre ftp.fr.debian.org
Je veux intaller iptables persistent car au démarrage toutes les règles ont disparu

Que dois-je faire ?

Merci
Afficher la suite 

Votre réponse

1 réponse

Messages postés
28650
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
17 décembre 2018
0
Merci
Bonjour,

Explication de l'erruer

Cette erreur indique que tu n'es pas connecté à Internet et/ou que le DNS est mal configuré. Tu peux vérifier ta configuration IP (et nous la reporter) avec les commandes :

ip route
cat /etc/resolv.conf


Précise la situation dans laquelle tu es

Il faudrait nous indiquer :
1) Comment tu te connectes à Internet. Ethernet / wifi ?
2) Est-ce que la configuration IP est automatique (i.e. configurable par DHCP), c'est le cas si tu te connectes avec une box ?
3) Passes-tu par proxy ?
4) As-tu installé une interface graphique qui te permettrait de tout configurer via network-manager ?
5) Tu veux utiliser du wifi, as-tu installé le firmware adéquat pour ta carte wifi ? Si ce n'est pas le cas, précise-nous ton modèle de carte wifi (cf
lspci
ou
lsusb
). Il te faudra récupérer le paquet adéquat via ethernet ou à l'aide d'un autre PC et le mettre sur clé USB.

Se connecter en ethernet en mode texte via une requête DHCP

Voici à titre indicatif comment tu pourrais récupérer du réseau via une box si tu es connecté en ethernet.

1) Récupère le nom de la carte ethernet (ce n'est pas
lo
)

Exemple : Ici c'est
wlp2s0
.

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: <bold>wlp2s0</bold>: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
    inet 192.168.0.11/24 brd 192.168.0.255 scope global dynamic noprefixroute wlp2s0
       valid_lft 862794sec preferred_lft 862794sec
...


3) Récupère une configuration IP (adresse, route, DNS) :

su - # Pour devenir root
dhclient wlp2s0
exit # Pour ne plus être root


4) Contrôle que ta configuration IP est correcte et fonctionnelle :

ip route
cat /etc/resolv.conf
ping -c2 www.google.fr


5) Si ça marche et que
/etc/apt/sources.list
est correct, alors tu devrais pouvoir utiliser
apt-get
(en root) :

su -
apt-get update
apt-get upgrade
apt-get install paquet1 paquet2
exit


Bonne chance
rialta86
Messages postés
1
Date d'inscription
mercredi 5 décembre 2018
Dernière intervention
5 décembre 2018
-
Bonjour
Voici la cmd ip route et cat



Pour le reste je suis sur debian 8 et suis sur ethernet. eth0 en dhcp et eth1 avec network manager car eth1 n'était pas visible dans ifconfig

pas de proxy

Quand je ping google.fr ça me dit "ping: unknown host www.google.fr

quand je fais dhlclient eth1 ça fait bash : dhlclient: commande introuvable.

J'espère être assez clair
mamiemando
Messages postés
28650
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
17 décembre 2018
-
Bonjour,

Plutôt que de faire une capture d'écran, fais plutôt un copier coller et utilise la balise de code (4e bouton au dessus de la boîte dans laquelle tu tapes ton message.

La commande dont je parlais est
dhclient
, tu as fait une faute de frappe.

Les routes semblent à premières vues correct, un DNS est configuré, mais celui-ci ne répond pas. Regarde si tu arrives à la pinger :

ping -c2 192.168.1.1


1) Si ce n'est pas le cas, refais ta requête DHCP et reporte-moi le résultat :

su -
dhclient -v eth1


Ensuite réessaye
ping -c2 192.168.1.1
:
  • Si la requête DHCP et/ou le ping échoue, la connexion n'est pas établie entre ton PC et ta box (problème de câble, carte réseau défectueuse, etc. ?)
  • Si la requête DHCP a marché, mais que tu ne parviens toujours pas à résoudre
    www.google.com
    , il y a un problème avec le DNS
    192.168.1.1
    . Dans ce cas, reporte-moi le résultat de :


ping -c2 8.8.8.8


2) Si le ping répond malgré l'absence de DNS, cela confirme le DNS configuré 192.168.1.1 est la cause du problème. Certaines boxes (e.g. livebox), agissent comme un relai DNS, ou permettent de régler quels services sont activés (e.g les freebox), essaye de voir si ça n'est pas la cause du problème. Vu ton fichier
/etc/resolv.conf
, il semblerait que tu utilises une livebox. Par le passé, je me souviens qu'utiliser le DNS de la livebox n'était pas une bonne idée (cela engendre des lenteurs au niveau des requêtes DNS, et il vaut carrément mieux interroger directement les DNS du FAI ou un DNS public).

Dans les deux cas, définir manuellement le DNS est une manière de contourner le problème. On peut dans un premier temps utiliser les DNS de google (
8.8.8.8
) ou avec l'IP d'un DNS root server si tu ne veux pas que tes requêtes DNS passent par google.

Pour cela, essaye de modifier en root avec nano le fichier
/etc/resolv.conf
avec la commande :

nano /etc/resolv.conf


Puis remplace
192.168.1.1
par
8.8.8.8
.

Bonne chance
Commenter la réponse de mamiemando